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Features


	Detailed Player development


	Training Analysis and Prediction


	Rating Prediction for your lineup


	Opponents Analysis


	Tons of statistics


	Many additional tools and modules










          

      

      

    

  

    
      
          
            
  
Installing HO!

When you land on the release page, you see a lof of different packages.
There are packages for the various OS, for different installation type
and with or without bundled JRE. In case you are not sure which one you
should download please read the first section of this document.


Select the right package


Installers or portable application

You can use HO! on Windows, Linux and macOS.

You can decide to install it on your machine (menu integration) or to
use it as a portable
application [https://en.wikipedia.org/wiki/Portable_application]. You
can have a single version of HO! installed on your machine but you might
have many portable versions. Hence, before upgrading your main HO! you
could decide to download a new version as a portable application to test
it first.



Manage Java dependency or use a bundled version

Hattrick Organizer! requires Java. HO! 3.0 requires a JRE >= 8.0 and HO!
4.0 a JRE ≥= 14.0. Starting with HO! 4.0, you are not force to install
java on your computer and you can instead download a version of HO!
which bundles the appropriate JRE. The choice is yours.

The HO! packages bundled with a JRE can be identified by their name
explicitly mentioning it. Those packages are also much heavier as they
contain the JRE.



Latest stable version

All versions of HO! can be downloaded from the release page but usually
you will want only to use the latest stable
version [https://github.com/akasolace/HO/releases/latest]




Directory structure

In the follow, the running application file are referring to: - /db -
user.json - error.log and output.log

/db folder contains whole you data. It is by far the most
important elements and the one you should always backup** before doing
anything fancy like testing a development version. In case you have
multiple team you will have multiple db folder.

user.json is the file linking your db folders to the user. In case
you have a single team and you kept HO! default it will look like:

	1

	[   {     "teamName": "user",     "dbName": "db",     "backupLevel": 3,     "isNtTeam": false   } ]








If you have multiple teams, it could be like:

	1

	[   {     "teamName": "FC Team",     "dbName": "db",     "backupLevel": 5,     "isNtTeam": false   },   {     "teamName": "Reserve Team",     "dbName": "db_reserve",     "backupLevel": 3,     "isNtTeam": false   },   {     "teamName": "National Team XXX",     "dbName": "dbNationalTeam",     "backupLevel": 3,     "isNtTeam": true   } ]








error.log and output.log are here for debug purposes


Portable application

If you are using a portable application all the files and folder will be
created within the application directory. You can move this directory
(e.g. on a USB stick or a network drive) and the app will continue to
work as expected.



Installed application

Under Windows and MacOS, you might have warning about the fact that HO! is a non-signed app.
You should still feel perfectly safe to install it, the message only means we are not paying
an (expensive) digital certificate to sign a free app. If you are interested on that topic, you can find more information
here [https://medium.com/vchaincodenotary/developers-unite-against-the-expensive-and-cumbersome-code-signing-certificates-d54342016a64]



Windows

If you installed HO! in Windows. You should have a HO! link in your
start menu that points toward the program executable. By default, HO!
installs itself in C:\Program Files\HO. The running application
documents (db/, logs/ and users.json) will be located in %appdata%\HO



Linux

If you installed HO! in Linux. You should have a HO! launcher that
points toward the program executable. By default, HO! installs itself in
/opt/HO. The running application files will be located in ~/.ho
except the error.log and output.log files which will created in
the installation directory



macOS

If you installed HO! in macOS. You usually have drag and drop HO! in
your applications folder. The running application files will be located
in /Library/Application Support/HO except the error.log and
output.log files which will created in the installation directory



How to upgrade from HO! 3.0 to HO! 4.0


Danger

Do not attempt upgrade before doing a backup of your db folder(s) !



It will not be possible to directly upgrade from HO! 3.0 to HO! 4.0, some (quick) manual steps will be required.

If you have only one team and never played with database/user administration, you only need to perform a fresh install of HO! 4.0 and to replace the content of the db folder with your existing database

If you have more than one team or that you played with database/user administration, you will have to manually create a file user.json that preserve the structure logic of your user.xml file. In that case you need to perform the following steps:


	before upgrading, check your existing HO structure: File>Database>Database/User administration
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	close your HO then make a backup from your db(s), they are in your installation folder directory-structure


	install HO! 4.0


	Launch HO! and go to File>Database>Database/User administration. Use buttons [Edit] and [Add] to adjust the db structure to your needs.


	replace the contents of db folder(s) with the backup(s) you made at step 2




Based on the previous example, here below is a side by side comparison of user.xml and user.json

user.xml:

  <?xml version='1.0' encoding='UTF-8' ?>
  <HoUsers>
  <User>
    <Name><![CDATA[FC Team]]></Name>
    <Url><![CDATA[jdbc:hsqldb:file:db/database]]></Url>
    <User><![CDATA[sa]]></User>
    <Password><![CDATA[]]></Password>
    <Driver><![CDATA[org.hsqldb.jdbcDriver]]></Driver>
    <BackupLevel>3</BackupLevel>
  </User>
  <User>
    <Name><![CDATA[Reserve Team]]></Name>
    <Url><![CDATA[jdbc:hsqldb:file:db_reserve/database]]></Url>
    <User><![CDATA[sa]]></User>
    <Password><![CDATA[]]></Password>
    <Driver><![CDATA[org.hsqldb.jdbcDriver]]></Driver>
    <BackupLevel>3</BackupLevel>
  </User>
  <User>
    <Name><![CDATA[National Team XXX]]></Name>
    <Url><![CDATA[jdbc:hsqldb:file:dbNationalTeam/database]]></Url>
    <User><![CDATA[sa]]></User>
    <Password><![CDATA[]]></Password>
    <Driver><![CDATA[org.hsqldb.jdbcDriver]]></Driver>
    <BackupLevel>3</BackupLevel>
  </User>
</HoUsers>





user.json:

[
{
   "teamName": "FC Team",
   "dbName": "db",
   "backupLevel": 5,
   "isNtTeam": false
   },
   {
    "teamName": "Reserve Team",
    "dbName": "db_reserve",
    "backupLevel": 3,
    "isNtTeam": false
    },
    {
    "teamName": "National Team XXX",
    "dbName": "dbNationalTeam",
    "backupLevel": 3,
    "isNtTeam": true
    }
   ]








First connection

For the first connection “F11” or, in the menu bar, “file” -> “download”

You see in the middle of the software a button with “open url” written
on it
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Screenshot 2020-05-24 at 19 48 32



Click on it and a link appears just below the button while opening a
hattrick page in your browser (if this page does not open, copy and
paste the link in the browser)

The link looks like this:
https://chpp.hattrick.org/oauth/authorize.aspx.…


[image: Screenshot 2020-05-24 at 19 48 46]

Screenshot 2020-05-24 at 19 48 46



Enter your login details as requested, Hattrick will give you a code
Copy the code into hattrick organizer
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Screenshot 2020-05-24 at 19 48 58



Little trick: select the code then CTRL + C to copy it and CTRL + V to
paste it
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Screenshot 2020-05-24 at 19 53 58



Please note that you should not enter your Hattrick password in any
third-party tools, make sure you do not enter your Hattrick password
anywhere in HO.



HRFs files

Storage of your hrf: it is not mandatory but if you decide to store
them, please make sure to select a folder in which you have writing
rights.

For another team: In the “Team Selection” window, select your other team
Then select the folder where you want to store his hrf (another folder
than that of your first team)



Modules

All modules are not enabled by default, select and set the ones you plan
to use (File → Preferences → Modules tab)


	automatic = activated in the tabs when HO starts!


	enabled = available in functions but not loaded at startup


	disabled = unavailable, unless you activate them ^^




for “team analyzer” and “Player analysis”, there are other options that
can be activated.



Restoring database

If you encounter any problem, make a backup from your folder db (and
file user.xml if you have more than one team)

In your db folder are zip files. Extract one of them into your current
folder. You get a warning message if you want to overwrite existing
files, confirm it with “Yes”.



Add another team to HO

It is possible to have multiple teams managed by HO! (c.f.
Second Team)





          

      

      

    

  

    
      
          
            
  
Functionalities



	NTHRF

	Second Team

	Feedback plugin

	Transfer Scout








          

      

      

    

  

    
      
          
            
  
NTHRF

If you’re a National Team coach, you can use Nthrf to get current players and their skills in HO! in just a few clicks.


	Start HO!


	Select from menu File>Database>Database/User administration


	two way, depend of you already have a team in HO or not :


	you already have your team in HO : Press Add


	it’s the first team in HO : Select single user and Press Edit






	Check National team


	Enter something as username, for example “National Team”.


	Press Save


	Press Close


	Quit HO!


	Start HO!


	In the new dialog, select the previously inserted username (e.g. “National Team”)


	First connexion





	For the first connection F11 or, in the menu bar, file>download


	You see in the middle of the software a button with “open url”
written on it


	Click on it and a link appears just below the button while opening a hattrick page in your browser (if this page does not open, copy and paste the link in the browser)


	The link looks like this: https://chpp.hattrick.org/oauth/authorize.aspx.…


	Enter your login details as requested, Hattrick will give you a code that you should copy into HO! (you can use CTRL-C and CTRL-V)





	Download





	F11 or, in the menu bar: file>download


	save your nthrf





	Import





	In the menu: file>import hrf from hard drive and select the Nthrf
file you just saved to have the data of your selection.


	You will see the internationals immediately in the list of players.





Note

You can only download the Nthrf file once per HO session! - the download button remains disabled after the first activation.






          

      

      

    

  

    
      
          
            
  
Second Team


To import your second team into HO!


	Backup your DB folder (inside your HO! folder)


	Start HO!


	Select from menu File>Database>Database/User administration


	Press Add


	Enter something as username, for example Second Team


	Press Save


	Press Close


	Restart HO!


	In the new dialog, select the previously inserted username


	When HO! starts, you will have an empty database. Select from menu File>Download and follow the instructions









          

      

      

    

  

    
      
          
            
  
Feedback plugin

In order to work, you have to be in one of the following situation:



	use the same language on HO and HT and the language to be sufficiently translated (if not the case please report the bug on GitHub and we will indicate you which term to translate to support your language


	use HT in English and HO in your language of choice







FeedBack have to be done after a team update, if not you will get a warning for update it at first

1. Click on the red double arrows will open the feedback plugin


[image: _images/feedback_1.png]

feedback plugin










	2. Set your lineup as recommended:

	
	fille position - indicated by the green box


	attitude and tactic
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lineup in HO should be as per the recommendation !









3. Copy the ratings on HT and paste them inside the feedback plugin


[image: _images/feedback_4.png]

copying ratings from HT (should be exactly similar to the lineup in HO!)



4. Sending the feedback

Once ready, click on  Refresh and have a qualitative check of the retaings deviation between HT and HO!.

If everything looks ok, click on Send !

Thanks for your participation  :-)

When enough data are collected we will improve rating formula and share result of analysis on HT forum !




          

      

      

    

  

    
      
          
            
  
Transfer Scout

In the tab “Squad”, you can simulate a player by “Skilltester”. In this
module, you can save your simulation player for later use.

There’s two way

1. you use new style and “Enable copy to clipboard” is checked under
“Appearance” in “Site Preferences” on Hattrick.


	Go to the page of a player over 17 years in hattrick, and use the
button copy from Hattrick “C” top right of the page.
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Hattrick Copy Button



2. “Use classic pages” is checked under legacy settings in your
“Site Preferences” on Hattrick.


	Go to the page of a player over 17 years in hattrick, and copy the
entire page: CTRL+A (to select the whole page) then CTRL+C (to copy
it to the clipboard).




This also works with the Youth Academy provided they have the required
age to enter in senior.

Then. they are for you to paste this information (CTRL+V) into
“Paste Playerdata” and click on the appropriate button “Apply”.

The buttons:


	Add : Add to list simulated player


	Replace list item : Select a player from the list, change the
features and update it


	Remove list item : Delete the selected player list


	Remove all player : Resetting the player list


	Mini-Scout : Reduced mode of this module


	Add player : Add your selected player to your squad to see its
contribution to your team; When you will restart HO!, the player will
no longer be present but you can add it again through this module.




NB : The language in HO and in hattrick must be the same for use this
module

NB2 : Don’t forget that loyalty and mother club bonus will be reset
if you buy such a player.




          

      

      

    

  

    
      
          
            
  
Contributing to HO

Whether you are a novice or experienced software developer, all contributions and suggestions are welcome! If you are looking to contribute to the HO codebase, the best place to start is the GitHub “issues” tab. This is also a great place for filing bug reports and making suggestions for ways in which we can improve the code and documentation.


Filing Issues

If you notice a bug in the code or in docs or have suggestions for how we can improve either, feel free to create an issue or a feature request on the GitHub “issues” tab using prefilled form. Those form contains some questions that will help us best address your issue.



Getting Started

The code is hosted on GitHub, so you will need to use Git to clone the project and make changes to the
codebase. It is also suggested to use IntelliJ IDEA as the main IDE. In case you decide to use
Eclipse make sure to add all the relevant filters in the .ignore accordingly.

In case of problems to set the development environment up, please consult our FAQ page to see
the list of the most common issues.



Contributing to the Codebase

In case you are not familiar with project contribution on GitHub, we suggest you read first some
appropriate documentation [https://guides.github.com/activities/forking/].

Before submitting your changes for review, make sure to pull latest version of master and check that
HO builds with your changes. Once your changes are ready to be submitted, make sure to push your
changes to GitHub before creating a pull request. You will most likely be asked to make additional
changes before it is finally ready to merge. However, once it’s ready, we will merge it, and you will
have successfully contributed to the codebase!



Translations

You can simply do so via PoEditor [https://poeditor.com/join/project/jCaWGL1JCl]

You need to fix both ‘Fuzzy translation’ (priority) and remaining untranslated terms.
In case the language in which you would like to contribute is not listed in the project page
please make a request by opening a ticket on GitHub





          

      

      

    

  

    
      
          
            
  
For developers



	FAQ

	Training Calculation








          

      

      

    

  

    
      
          
            
  
FAQ


	IntelliJ IDEA performs gradle tasks before starting HO

These gradle tasks are only required to generate the release artifacts of HO. If you only want to simply run/debug HO in the IDE use the following settings (invoke Ctrl+Alt+S):

Settings->Build, Execution, Deployment->Build Tools->Gradle

Select

Build and run using: IntelliJ IDEA

Run tests using: IntelliJ IDEA





[image: _images/ijsettings.png]



	Gradle: could not get unknown property ``POEDITOR_APIKEY`` for object of type ``de.jansauer.poeditor.POEditorExtension``




In case you don’t have a POEditor key, you simply need to remove the related reference: in ´build.gradle´ comment the line
referring to POEDITOR_APIKEY

// apiKey = POEDITOR_APIKEY´








	MacOS: ``Aqua`` exception: at runtime a series of runtime exceptions are thrown, and the UI doesn’t work as expected…




Make sure that the following VM Arguments is set -Dapple.laf.useScreenMenuBar=true -Dapple.awt.showGroupBox=true




          

      

      

    

  

    
      
          
            
  
Training Calculation


	Subskills


	Download (F11)
current HOModel is updated


	HOModel.calcSubskills is called


	Find the training weeks since last stored hrf (homodel)


	call TrainingManager.instance().calculateTraining






	Recalc Subskills











	Trained this week

blabla
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Changelist HO! 4.1


	fixes NPE events in module Player Analysis and SpecialEvents (#797)




Changelist HO! 4.0



Some numbers:


	277 commits


	794 files changed (20’997 additions and 21’491 deletions)


	108 issues closed


	9 contributors






Highlights


	New build process:


	HO! now requires Java 14 but artefacts including JRE are made available


	in-app upgrade is now supported


	directory structure has changed (db location, log files, …)






	[FEAT] Improved GUI, new themes, and implemented dark mode. #85


	[FEAT] Complete rewrite of Special Events module






Detailed Changelog


Squad


	[FIX] Remove lag in sync between tables in Squad #465


	[FIX] Provide better default for initial position of player comparison divider.






Team Analyser


	[FEAT] Save adjusted lineup ratings of MatchPredictionPanel in an extra row #66






Rating


	[FIX] Fixes Long Shots tactic level calculation






Matches


	[FIX] Some icons fixes in match report


	[FEAT] Information about extra time or penalty shoot out in match result #561






Lineup


	[FEAT] Provide better defaults for initial position of dividers.


	[FEAT] Edit man marking match order [#660]


	[FIX] Fix bug in download of man marking match orders [#632]


	[FIX] Fix bug in upload of position change match orders [#633]






IFA


	[FIX] add supports for 9 new leagues: Belize, Madagascar, Botswana, Saint Vincent and the Grenadines, Myanmar, Zambia, San Marino, Puerto Rico and Haiti [#539]






Training


	[FIX] Fix bug of season correction calculation. Training effect table shows wrong seasons in week 16 [#539]


	[FIX] Subskill recalc takes into account training that took place before the first hrf download [#512]


	[FIX] Fix bug of training effect of Walkover matches [#623]


	[FEAT] Individual training plans for each player in training preview [#587]






Misc


	[FEAT] Remove jcalendar dependency.


	[FIX] ExperienceViewer removed [#503]


	[FIX] Avoid potential infinite loop at startup. [#584]


	[FIX] Layout issue in multiple screen setup. [#618]


	[FEAT] Remove all printing functionality.


	[FEAT] Remove player state colour, and display icons instead in Lineup.


	[FEAT] Refactor progress bar display [#722]






League


	[FEAT] Make Promotion status more visible. [#521]







Translations


	HO! is currently available in 35 languages thanks to the work of 78 translators. The translation status varies a lot from one language to another. If you can help in a language requiring attention please join in the effort and register on POeditor [https://poeditor.com/join/project/jCaWGL1JCl]:


	Translators contribution since the previous release (number of translated terms):




| Contributor       | Translations | Percentage |
|——————-|————–|————|
| Kimmo             | 843          | 48.03      |
| Andreas           | 745          | 42.45      |
| _KOHb_            | 436          | 24.84      |
| Moorhuhninho      | 409          | 23.3       |
| TeamBMW           | 349          | 19.89      |
| Csaba             | 230          | 13.11      |
| André             | 207          | 11.79      |
| h3t3r0            | 139          | 7.92       |
| asteins           | 79           | 4.5        |
| Hakkarainen       | 62           | 3.53       |
| DavidatorusF      | 61           | 3.48       |
| Manny             | 60           | 3.42       |
| Baler0            | 54           | 3.08       |
| Stef              | 46           | 2.62       |
| dzsoo             | 44           | 2.51       |
| Bartosz           | 41           | 2.34       |
| murko             | 39           | 2.22       |
| Volker            | 38           | 2.17       |
| sich              | 38           | 2.17       |
| Sebas90           | 32           | 1.82       |
| akasolace         | 31           | 1.77       |
| Lidegand          | 29           | 1.65       |
| Saleh             | 14           | 0.8        |
| LeSchmuh          | 11           | 0.63       |
| Ricardo           | 6            | 0.34       |
| Motavali          | 5            | 0.28       |
| karelant.         | 4            | 0.23       |
| Philipp           | 2            | 0.11       |
| Sumame.           | 2            | 0.11       |
| RaV               | 1            | 0.06       |
| Total translated: | 4057         | 6.42       |
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Changelist HO! 5.0


Some numbers:


	xxx commits


	xxx files changed (xxx additions and xxx deletions)


	xxx issues closed


	xx contributors






Highlights


	complete makeover of the statistics module (#788)


	improving consistency of dark themes


	preview of new module Youth academy (#367)






Detailed Changelog


GUI


	theming of training bar indicators






Finance


	all information relative to Finance are now stored in the database (#793)






Statistics


	complete makeover of the statistics module: more data, more visible …. (#788)






Squad


	Separate rating and match date columns for easier sorting. (#895)


	adjusting of experience subskill is displayed in player details panel (#1023)






Team Analyser


	tuning simulation (#865)


	fix npe if system configurations of team analyzer are not available in database (#956)






Rating


	new default model






Matches


	new match location filter (home/away/neutral/all) on Statistics tab (#470)


	fix display of national team matches (#1048)






Lineup


	Match orders remove substitution limit (#856)


	complete revamp of lineup panel


	Separate rating and match date columns for easier sorting. (#895)






IFA



Training


	many buf fixes


	fix training recap table’s resetting scroll positions on table refresh  (#1011)






Misc


	fix issue with user preferences (incl. OAuth access token) not being saved upon exiting HO. (#811)


	improved handling of timezone accross the app


	sanitizing of preferences panel


	automatic check for new HO! version after HRF-Download (#1019)


	configurable in File -> Preferences -> Release Channels






	fix NT team players’ name download (#1025)






League




Translations


	HO! is currently available in xxx languages thanks to the work of xxx translators. The translation status varies a lot from one language to another. If you can help in a language requiring attention please join in the effort and register on POeditor [https://poeditor.com/join/project/jCaWGL1JCl]:


	Translators contribution since the previous release (number of translated terms)
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Highlights


	refactoring player details panel showing players’ avatars now (#1349)


	refactoring of lineup panel (#1267)


	enable more than three teams (#1415)






Detailed Changelog [https://github.com/akasolace/HO/issues?q=milestone%3A6.0]


Database


	reducing data base file’s disk space accelerates HO startup duration (#958)


	fix bug in hrf file import (#1445)


	About dialog shows path of database and logs folder (#1576)






Squad


	refactoring player details panel showing players’ avatars now (#1349)


	display jersey numbers greater than 49 (#1410)


	download and display players’ category, statement and owner notes (#1441)


	shirt number column settings reset to editable (#1454)


	hrf file list shows training week instead of match day (#1452)


	skill recalculation no longer ignores very first downloaded hrf file (#1489)


	fix error of skill recalculation of replaced players (#1489)


	fix another recalculation error concerning wrong skill up handling (#1519)






Team Analyser


	display confidence and team spirit of nt team opponents (#1305)






Rating


	Initial calculation of the ratings takes into account the trainer type (#1281)


	calculate effect of man marking on ratings (#682)






Matches


	fix error on selecting matches without downloaded highlights (#1553)


	fix sorting of hatstat columns (#1598)






Lineup


	refactoring, including loading and storing of lineup templates (#1267)


	fixed a bug when downloading team logos (#1300)


	substitutions of the same minute can be ordered (#1039)


	fixed goalkeeper could not be selected as team captain (#1340)


	fix null pointer exception in lineup assistant if no current lineup exists (#1496, #1571)






Statistics


	fix chart time axis (#1561)






NT


	fix download xml parse errors (#1305)


	tracking confidence and team spirit of nt teams (#1305)






Training


	fix NPE in training tab in America-based timezones (#1296)


	enable cell editing in future training table (#1396)


	fix concurrent modification exception on training refresh (#1430)


	reimport of hrf files sets training information (#1469)






League


	fix download of power rating (not only one team per match) (#1293)


	download all matches of latest league match day (#1373)


	fix download of old league data (#1413)


	initial width of league table pane adjusted (#1451)






Youth


	fix bug in potential calculation due to wrong isTop3 skill tagging (#1278)


	fix escaping of youth team names (#1295)


	fix set pieces is not limited by top3 skill rules (#1309)


	fix settings loss of the first table columns (#1402)


	show youth player’s training development as line charts (#1418)






Misc


	fix finance bug concerning missing spectators’ income in misc module (#1282)


	fix last weeks profit/loss, temporary income sum and missing sponsors bonus (#1301)


	fix CHPP token not being saved when exiting HO on macos (#1291)


	fix portable HO update error when java version is changed (#1545)







QA Team


	masterpatje does a great job of testing the development versions of the HO to get rid of even the last bugs in it.






Translations

Reports by Contributors - Dec 20, 2021 - August 05, 2022


	Foppe	690


	brokenelevator 510


	Pablo 313


	Ante 218


	_KOHb_	110


	Adrian 107


	Fresty di Lot 101


	sich	100


	Lidegand 	98


	akasolace	96


	Frank 94


	TeamBMW 75


	anti_anti 69


	Moorhuhninho	67


	wsbrenk 34


	dzsoo 18


	Sophia 17


	Csaba 14


	Michał 11


	Motavali 2


	Philipp 1


	Total translated:	2745
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	fixes NPE events in module Player Analysis and SpecialEvents (#797)




Changelist HO! 4.0



Some numbers:


	277 commits


	794 files changed (20’997 additions and 21’491 deletions)


	108 issues closed


	9 contributors






Highlights


	New build process:


	HO! now requires Java 14 but artefacts including JRE are made available


	in-app upgrade is now supported


	directory structure has changed (db location, log files, …)






	[FEAT] Improved GUI, new themes, and implemented dark mode. #85


	[FEAT] Complete rewrite of Special Events module






Detailed Changelog


Squad


	[FIX] Remove lag in sync between tables in Squad #465


	[FIX] Provide better default for initial position of player comparison divider.






Team Analyser


	[FEAT] Save adjusted lineup ratings of MatchPredictionPanel in an extra row #66






Rating


	[FIX] Fixes Long Shots tactic level calculation






Matches


	[FIX] Some icons fixes in match report


	[FEAT] Information about extra time or penalty shoot out in match result #561






Lineup


	[FEAT] Provide better defaults for initial position of dividers.


	[FEAT] Edit man marking match order [#660]


	[FIX] Fix bug in download of man marking match orders [#632]


	[FIX] Fix bug in upload of position change match orders [#633]






IFA


	[FIX] add supports for 9 new leagues: Belize, Madagascar, Botswana, Saint Vincent and the Grenadines, Myanmar, Zambia, San Marino, Puerto Rico and Haiti [#539]






Training


	[FIX] Fix bug of season correction calculation. Training effect table shows wrong seasons in week 16 [#539]


	[FIX] Subskill recalc takes into account training that took place before the first hrf download [#512]


	[FIX] Fix bug of training effect of Walkover matches [#623]


	[FEAT] Individual training plans for each player in training preview [#587]






Misc


	[FEAT] Remove jcalendar dependency.


	[FIX] ExperienceViewer removed [#503]


	[FIX] Avoid potential infinite loop at startup. [#584]


	[FIX] Layout issue in multiple screen setup. [#618]


	[FEAT] Remove all printing functionality.


	[FEAT] Remove player state colour, and display icons instead in Lineup.


	[FEAT] Refactor progress bar display [#722]






League


	[FEAT] Make Promotion status more visible. [#521]







Translations


	HO! is currently available in 35 languages thanks to the work of 78 translators. The translation status varies a lot from one language to another. If you can help in a language requiring attention please join in the effort and register on POeditor [https://poeditor.com/join/project/jCaWGL1JCl]:


	Translators contribution since the previous release (number of translated terms):




| Contributor       | Translations | Percentage |
|——————-|————–|————|
| Kimmo             | 843          | 48.03      |
| Andreas           | 745          | 42.45      |
| _KOHb_            | 436          | 24.84      |
| Moorhuhninho      | 409          | 23.3       |
| TeamBMW           | 349          | 19.89      |
| Csaba             | 230          | 13.11      |
| André             | 207          | 11.79      |
| h3t3r0            | 139          | 7.92       |
| asteins           | 79           | 4.5        |
| Hakkarainen       | 62           | 3.53       |
| DavidatorusF      | 61           | 3.48       |
| Manny             | 60           | 3.42       |
| Baler0            | 54           | 3.08       |
| Stef              | 46           | 2.62       |
| dzsoo             | 44           | 2.51       |
| Bartosz           | 41           | 2.34       |
| murko             | 39           | 2.22       |
| Volker            | 38           | 2.17       |
| sich              | 38           | 2.17       |
| Sebas90           | 32           | 1.82       |
| akasolace         | 31           | 1.77       |
| Lidegand          | 29           | 1.65       |
| Saleh             | 14           | 0.8        |
| LeSchmuh          | 11           | 0.63       |
| Ricardo           | 6            | 0.34       |
| Motavali          | 5            | 0.28       |
| karelant.         | 4            | 0.23       |
| Philipp           | 2            | 0.11       |
| Sumame.           | 2            | 0.11       |
| RaV               | 1            | 0.06       |
| Total translated: | 4057         | 6.42       |
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Changelist HO! 5.0


Some numbers:


	xxx commits


	xxx files changed (xxx additions and xxx deletions)


	xxx issues closed


	xx contributors






Highlights


	complete makeover of the statistics module (#788)


	improving consistency of dark themes


	preview of new module Youth academy (#367)






Detailed Changelog


GUI


	theming of training bar indicators






Finance


	all information relative to Finance are now stored in the database (#793)






Statistics


	complete makeover of the statistics module: more data, more visible …. (#788)






Squad


	Separate rating and match date columns for easier sorting. (#895)


	adjusting of experience subskill is displayed in player details panel (#1023)






Team Analyser


	tuning simulation (#865)


	fix npe if system configurations of team analyzer are not available in database (#956)






Rating


	new default model






Matches


	new match location filter (home/away/neutral/all) on Statistics tab (#470)


	fix display of national team matches (#1048)






Lineup


	Match orders remove substitution limit (#856)


	complete revamp of lineup panel


	Separate rating and match date columns for easier sorting. (#895)






IFA



Training


	many buf fixes


	fix training recap table’s resetting scroll positions on table refresh  (#1011)






Misc


	fix issue with user preferences (incl. OAuth access token) not being saved upon exiting HO. (#811)


	improved handling of timezone accross the app


	sanitizing of preferences panel


	automatic check for new HO! version after HRF-Download (#1019)


	configurable in File -> Preferences -> Release Channels






	fix NT team players’ name download (#1025)






League




Translations


	HO! is currently available in xxx languages thanks to the work of xxx translators. The translation status varies a lot from one language to another. If you can help in a language requiring attention please join in the effort and register on POeditor [https://poeditor.com/join/project/jCaWGL1JCl]:


	Translators contribution since the previous release (number of translated terms)
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Changelist HO! 4.1


	fixes NPE events in module Player Analysis and SpecialEvents (#797)
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