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Helper Tool for online-manager Hattrick

• Detailed Player development

• Training Analysis and Prediction

• Rating Prediction for your lineup

• Opponents Analysis

• Tons of statistics

• Many additional tools and modules

Contents 1
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CHAPTER 1

Installing HO!

When you land on the release page, you see a lof of different packages. There are packages for the various OS, for
different installation type and with or without bundled JRE. In case you are not sure which one you should download
please read the first section of this document.

1.1 Select the right package

1.1.1 Installers or portable application

You can use HO! on Windows, Linux and macOS.

You can decide to install it on your machine (menu integration) or to use it as a portable application. You can have a
single version of HO! installed on your machine but you might have many portable versions. Hence, before upgrading
your main HO! you could decide to download a new version as a portable application to test it first.

1.1.2 Manage Java dependency or use a bundled version

Hattrick Organizer! requires Java. HO! 3.0 requires a JRE >= 8.0 and HO! 4.0 a JRE = 14.0. Starting with HO! 4.0,
you are not force to install java on your computer and you can instead download a version of HO! which bundles the
appropriate JRE. The choice is yours.

The HO! packages bundled with a JRE can be identified by their name explicitly mentioning it. Those packages are
also much heavier as they contain the JRE.

1.1.3 Latest stable version

All versions of HO! can be downloaded from the release page but usually you will want only to use the latest stable
version
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1.2 Directory structure

In the follow, the running application file are referring to: - /db - user.json - error.log and output.log

/db folder contains whole you data. It is by far the most important elements and the one you should always backup**
before doing anything fancy like testing a development version. In case you have multiple team you will have multiple
db folder.

user.json is the file linking your db folders to the user. In case you have a single team and you kept HO! default it will
look like:

1 [ { "teamName": "user", "dbName": "db", "backupLevel": 3, "isNtTeam
→˓": false } ]

If you have multiple teams, it could be like:

1 [ { "teamName": "FC Team", "dbName": "db", "backupLevel": 5,
→˓"isNtTeam": false }, { "teamName": "Reserve Team", "dbName": "db_reserve
→˓", "backupLevel": 3, "isNtTeam": false }, { "teamName": "National
→˓Team XXX", "dbName": "dbNationalTeam", "backupLevel": 3, "isNtTeam":
→˓true } ]

error.log and output.log are here for debug purposes

1.2.1 Portable application

If you are using a portable application all the files and folder will be created within the application directory. You can
move this directory (e.g. on a USB stick or a network drive) and the app will continue to work as expected.

1.2.2 Installed application

Under Windows and MacOS, you might have warning about the fact that HO! is a non-signed app. You should still
feel perfectly safe to install it, the message only means we are not paying an (expensive) digital certificate to sign a
free app. If you are interested on that topic, you can find more information here

1.2.3 Windows

If you installed HO! in Windows. You should have a HO! link in your start menu that points toward the program
executable. By default, HO! installs itself in C:\Program Files\HO. The running application documents (db/,
logs/ and users.json) will be located in %appdata%\HO

1.2.4 Linux

If you installed HO! in Linux. You should have a HO! launcher that points toward the program executable. By default,
HO! installs itself in /opt/HO. The running application files will be located in ~/.ho except the error.log and
output.log files which will created in the installation directory

4 Chapter 1. Installing HO!
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1.2.5 macOS

If you installed HO! in macOS. You usually have drag and drop HO! in your applications folder. The running applica-
tion files will be located in /Library/Application Support/HO except the error.log and output.log
files which will created in the installation directory

1.2.6 How to upgrade from HO! 3.0 to HO! 4.0

Danger: Do not attempt upgrade before doing a backup of your db folder(s) !

It will not be possible to directly upgrade from HO! 3.0 to HO! 4.0, some (quick) manual steps will be required.

If you have only one team and never played with database/user administration, you only need to perform a fresh
install of HO! 4.0 and to replace the content of the db folder with your existing database

If you have more than one team or that you played with database/user administration, you will have to manually
create a file user.json that preserve the structure logic of your user.xml file. In that case you need to perform the
following steps:

1) before upgrading, check your existing HO structure: File>Database>Database/User administration

2) close your HO then make a backup from your db(s), they are in your installation folder directory-structure

3) install HO! 4.0

4) Launch HO! and go to File>Database>Database/User administration. Use buttons [Edit] and [Add] to adjust
the db structure to your needs.

5) replace the contents of db folder(s) with the backup(s) you made at step 2

Based on the previous example, here below is a side by side comparison of user.xml and user.json

user.xml:

1.2. Directory structure 5
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<?xml version='1.0' encoding='UTF-8' ?>
<HoUsers>
<User>
<Name><![CDATA[FC Team]]></Name>
<Url><![CDATA[jdbc:hsqldb:file:db/database]]></Url>
<User><![CDATA[sa]]></User>
<Password><![CDATA[]]></Password>
<Driver><![CDATA[org.hsqldb.jdbcDriver]]></Driver>
<BackupLevel>3</BackupLevel>

</User>
<User>
<Name><![CDATA[Reserve Team]]></Name>
<Url><![CDATA[jdbc:hsqldb:file:db_reserve/database]]></Url>
<User><![CDATA[sa]]></User>
<Password><![CDATA[]]></Password>
<Driver><![CDATA[org.hsqldb.jdbcDriver]]></Driver>
<BackupLevel>3</BackupLevel>

</User>
<User>
<Name><![CDATA[National Team XXX]]></Name>
<Url><![CDATA[jdbc:hsqldb:file:dbNationalTeam/database]]></Url>
<User><![CDATA[sa]]></User>
<Password><![CDATA[]]></Password>
<Driver><![CDATA[org.hsqldb.jdbcDriver]]></Driver>
<BackupLevel>3</BackupLevel>

</User>
</HoUsers>

user.json:

[
{

"teamName": "FC Team",
"dbName": "db",
"backupLevel": 5,
"isNtTeam": false
},
{
"teamName": "Reserve Team",
"dbName": "db_reserve",
"backupLevel": 3,
"isNtTeam": false
},
{
"teamName": "National Team XXX",
"dbName": "dbNationalTeam",
"backupLevel": 3,
"isNtTeam": true
}

]

1.3 First connection

For the first connection “F11” or, in the menu bar, “file” -> “download”

You see in the middle of the software a button with “open url” written on it

6 Chapter 1. Installing HO!
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Fig. 1: Screenshot 2020-05-24 at 19 48 32

Click on it and a link appears just below the button while opening a hattrick page in your browser (if this page does
not open, copy and paste the link in the browser)

The link looks like this: https://chpp.hattrick.org/oauth/authorize.aspx.. . .

Enter your login details as requested, Hattrick will give you a code Copy the code into hattrick organizer

Little trick: select the code then CTRL + C to copy it and CTRL + V to paste it

Please note that you should not enter your Hattrick password in any third-party tools, make sure you do not enter your
Hattrick password anywhere in HO.

1.4 HRFs files

Storage of your hrf: it is not mandatory but if you decide to store them, please make sure to select a folder in which
you have writing rights.

For another team: In the “Team Selection” window, select your other team Then select the folder where you want to
store his hrf (another folder than that of your first team)

1.5 Modules

All modules are not enabled by default, select and set the ones you plan to use (File → Preferences → Modules tab)

• automatic = activated in the tabs when HO starts!

• enabled = available in functions but not loaded at startup

• disabled = unavailable, unless you activate them ^^

for “team analyzer” and “Player analysis”, there are other options that can be activated.

1.4. HRFs files 7
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Fig. 2: Screenshot 2020-05-24 at 19 48 46

Fig. 3: Screenshot 2020-05-24 at 19 48 58
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Fig. 4: Screenshot 2020-05-24 at 19 53 58

1.6 Restoring database

If you encounter any problem, make a backup from your folder db (and file user.xml if you have more than one team)

In your db folder are zip files. Extract one of them into your current folder. You get a warning message if you want to
overwrite existing files, confirm it with “Yes”.

1.7 Add another team to HO

It is possible to have multiple teams managed by HO! (c.f. Second Team)

1.6. Restoring database 9
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CHAPTER 2

Functionalities

2.1 NTHRF

If you’re a National Team coach, you can use Nthrf to get current players and their skills in HO! in just a few clicks.

1. Start HO!

2. Select from menu File>Database>Database/User administration

3. two way, depend of you already have a team in HO or not :

• you already have your team in HO : Press Add

• it’s the first team in HO : Select single user and Press Edit

4. Check National team

5. Enter something as username, for example “National Team”.

6. Press Save

7. Press Close

8. Quit HO!

9. Start HO!

10. In the new dialog, select the previously inserted username (e.g. “National Team”)

11. First connexion

• For the first connection F11 or, in the menu bar, file>download

• You see in the middle of the software a button with “open url” written on it

• Click on it and a link appears just below the button while opening a hattrick page in your browser (if this page
does not open, copy and paste the link in the browser)

• The link looks like this: https://chpp.hattrick.org/oauth/authorize.aspx.. . .
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• Enter your login details as requested, Hattrick will give you a code that you should copy into HO! (you can use
CTRL-C and CTRL-V)

12. Download

• F11 or, in the menu bar: file>download

• save your nthrf

13. Import

• In the menu: file>import hrf from hard drive and select the Nthrf file you just saved to have the data of your
selection.

• You will see the internationals immediately in the list of players.

Note: You can only download the Nthrf file once per HO session! - the download button remains disabled after the
first activation.

2.2 Second Team

To import your second team into HO!

1. Backup your DB folder (inside your HO! folder)

2. Start HO!

3. Select from menu File>Database>Database/User administration

4. Press Add

5. Enter something as username, for example Second Team

6. Press Save

7. Press Close

8. Restart HO!

9. In the new dialog, select the previously inserted username

10. When HO! starts, you will have an empty database. Select from menu File>Download and follow the in-
structions

2.3 Feedback plugin

In order to work, you have to be in one of the following situation:

• use the same language on HO and HT and the language to be sufficiently translated (if not the case please
report the bug on GitHub and we will indicate you which term to translate to support your language

• use HT in English and HO in your language of choice

FeedBack have to be done after a team update, if not you will get a warning for update it at first

1. Click on the red double arrows will open the feedback plugin

12 Chapter 2. Functionalities
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Fig. 1: feedback plugin

2. Set your lineup as recommended:

• fille position - indicated by the green box

• attitude and tactic

2.3. Feedback plugin 13
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Fig. 2: lineup in HO should be as per the recommendation !

3. Copy the ratings on HT and paste them inside the feedback plugin

4. Sending the feedback

Once ready, click on Refresh and have a qualitative check of the retaings deviation between HT and HO!.

If everything looks ok, click on Send !

Thanks for your participation :-)

14 Chapter 2. Functionalities
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Fig. 3: copying ratings from HT (should be exactly similar to the lineup in HO!)

When enough data are collected we will improve rating formula and share result of analysis on HT forum !

2.4 Transfer Scout

In the tab “Squad”, you can simulate a player by “Skilltester”. In this module, you can save your simulation player for
later use.

There’s two way

1. you use new style and “Enable copy to clipboard” is checked under “Appearance” in “Site Preferences” on Hattrick.

• Go to the page of a player over 17 years in hattrick, and use the button copy from Hattrick “C” top right of the
page.

Fig. 4: Hattrick Copy Button

2. “Use classic pages” is checked under legacy settings in your “Site Preferences” on Hattrick.

• Go to the page of a player over 17 years in hattrick, and copy the entire page: CTRL+A (to select the whole
page) then CTRL+C (to copy it to the clipboard).

This also works with the Youth Academy provided they have the required age to enter in senior.

2.4. Transfer Scout 15
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Then. they are for you to paste this information (CTRL+V) into “Paste Playerdata” and click on the appropriate button
“Apply”.

The buttons:

• Add : Add to list simulated player

• Replace list item : Select a player from the list, change the features and update it

• Remove list item : Delete the selected player list

• Remove all player : Resetting the player list

• Mini-Scout : Reduced mode of this module

• Add player : Add your selected player to your squad to see its contribution to your team; When you will restart
HO!, the player will no longer be present but you can add it again through this module.

NB : The language in HO and in hattrick must be the same for use this module

NB2 : Don’t forget that loyalty and mother club bonus will be reset if you buy such a player.

16 Chapter 2. Functionalities



CHAPTER 3

Contributing to HO

Whether you are a novice or experienced software developer, all contributions and suggestions are welcome! If you
are looking to contribute to the HO codebase, the best place to start is the GitHub “issues” tab. This is also a great
place for filing bug reports and making suggestions for ways in which we can improve the code and documentation.

3.1 Filing Issues

If you notice a bug in the code or in docs or have suggestions for how we can improve either, feel free to create an
issue or a feature request on the GitHub “issues” tab using prefilled form. Those form contains some questions that
will help us best address your issue.

3.2 Getting Started

The code is hosted on GitHub, so you will need to use Git to clone the project and make changes to the codebase.
It is also suggested to use IntelliJ IDEA as the main IDE. In case you decide to use Eclipse make sure to add all the
relevant filters in the .ignore accordingly.

In case of problems to set the development environment up, please consult our FAQ page to see the list of the most
common issues.

3.3 Contributing to the Codebase

In case you are not familiar with project contribution on GitHub, we suggest you read first some appropriate docu-
mentation.

Before submitting your changes for review, make sure to pull latest version of master and check that HO builds with
your changes. Once your changes are ready to be submitted, make sure to push your changes to GitHub before creating
a pull request. You will most likely be asked to make additional changes before it is finally ready to merge. However,
once it’s ready, we will merge it, and you will have successfully contributed to the codebase!

17
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3.4 Translations

You can simply do so via PoEditor

You need to fix both ‘Fuzzy translation’ (priority) and remaining untranslated terms. In case the language in which
you would like to contribute is not listed in the project page please make a request by opening a ticket on GitHub

18 Chapter 3. Contributing to HO
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CHAPTER 4

For developers

4.1 FAQ

• IntelliJ IDEA performs gradle tasks before starting HO

These gradle tasks are only required to generate the release artifacts of HO. If you only want to simply run/debug
HO in the IDE use the following settings (invoke Ctrl+Alt+S):

Settings->Build, Execution, Deployment->Build Tools->Gradle

Select

Build and run using: IntelliJ IDEA

Run tests using: IntelliJ IDEA

19
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• Gradle: could not get unknown property ‘‘POEDITOR_APIKEY‘‘ for object of type
‘‘de.jansauer.poeditor.POEditorExtension‘‘

In case you don’t have a POEditor key, you simply need to remove the related reference: in ´build.gradle´ comment
the line referring to POEDITOR_APIKEY

// apiKey = POEDITOR_APIKEY´

• MacOS: ‘‘Aqua‘‘ exception: at runtime a series of runtime exceptions are thrown, and the UI doesn’t
work as expected. . .

Make sure that the following VM Arguments is set -Dapple.laf.useScreenMenuBar=true -Dapple.
awt.showGroupBox=true

4.2 Training Calculation

• Subskills

– Download (F11) current HOModel is updated

* HOModel.calcSubskills is called

* Find the training weeks since last stored hrf (homodel)

20 Chapter 4. For developers
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* call TrainingManager.instance().calculateTraining

– Recalc Subskills

• Trained this week

blabla

4.2. Training Calculation 21
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